QCAD - Supported Platforms

QCAD

The latest stable release of QCAD has been tested under:

  • Windows: 10, 8.1, 8, 7, Vista, 2000, XP*. 32bit and 64bit.
  • macOS: Mojave (10.14), High Sierra (10.13), Sierra (10.12), El Capitan (10.11), Yosemite (10.10), Mavericks (10.9), Mountain Lion (10.8), Lion (10.7)
  • Linux: Most modern 32bit and 64bit distributions.

*QCAD/CAM might or might not work on an individual Windows XP installation, depending on graphics cards drivers. Please try the free trial version first.

Supported C++ Compilers and Qt Versions

The following list is intended for developers who are choosing a Qt version to compile QCAD against.

All listed Qt version / platform combinations have been tested. Other, not listed Qt versions might or might not work.

Some Qt versions are explicitly NOT recommended due to known significant bugs in Qt.

  • Windows:
    • Compilers / SDKs:
      • MSVC 2010 32bit / Microsoft Windows SDK for Windows 7 and .NET Framework 4
      • MSVC 2013 64bit / Microsoft Visual Studio 2013 SDK
    • Qt Versions:
      • Qt 4.7.4 is recommended for older platforms
      • Qt 4.8.7 is NOT recommended:
        • FS#1241: no interaction with widgets, graphics view possible
      • Qt 5.5.1 is recommended with patches for:
  • macOS:
    • Compilers:
      • XCode
    • Qt Versions:
      • Patches recommended for all Qt Versions:
        • QTBUG-69955: Fonts display with incorrect weights in macOS 10.14 Mojave (Patch)
      • Qt 4.8.6 is recommended for older platforms
      • Qt 5.5.0 is NOT recommended:
      • Qt 5.5.1 is recommended with patches for:
      • Qt 5.6.1 is recommended with patches for:
      • Qt 5.7.0 is NOT recommended:
      • Qt 5.7.1 is NOT recommended:
      • Qt 5.8.0 is NOT recommended:
      • Qt 5.10.0 is recommended with patches for:
      • Qt 5.10.1 is recommended with patches for:
      • Qt 5.11.2 is NOT recommended:
      • Qt 5.12.0 is NOT recommended:
  • Linux:
    • Compilers:
      • gcc 4.4.x
    • Qt Versions:
      • Qt 4.8.6 is recommended for older platforms
      • Qt 5.5.1 is recommended with patches for:
      • Qt 5.8.0 is NOT recommended: