Page 1 of 1

[solved] No Visible Lines

Posted: Fri Oct 04, 2019 2:09 pm
by bvmetry
I download QCAD and created the Community Edition to edit a simple 2D floor plan. Everything worked fine. Now or some reason I can not draw any lines, rectangles, etc. I went through all my settings and everything look good. All Layers are visible, colors are good, can't find anything wrong. Today I removed QCAD from my Mac (running 10.14.6), download a complete new version of QCAD, opened it up to a blank screen, select the line icon to add a line and nothing. I did that without changing any defaults. Do you have any ideas on what can be wrong?

Re: No lines visible

Posted: Fri Oct 04, 2019 6:00 pm
by Husky
Check the Layer for locked status - padlock symbol in layer list. If locked unlock it. If it isn't the problem please save the drawing and upload it to this forum. We'll check it then ...

Re: No lines visible

Posted: Sun Oct 06, 2019 2:55 pm
by bvmetry
Thank you for your reply. Well, I've got the line working again, but not like it was before. Here's what happens. I select the line icon, but nothing is visible until I press the + (free snap or FS) icon. The Command Line shows "Next Point" but nothing shows on the screen. So to draw a 2 point line and have it snap to the end of the line, I need to select the line icon, then select the + icon, then select the End Snap (ES) icon and then draw the line. It wasn't like that before. Before I simply select the line icon and it would auto snap to the ends and I would draw the line. How can I get it back to the way it was? It's got to be a setting.

Re: No lines visible PROBLEM SOLVED

Posted: Sun Oct 06, 2019 3:23 pm
by bvmetry
Problem Solved. I went into the Auto Snap Preferences and selected "Free Positioning".