How to switch to IJK absolute

Discussions around the CAM Add-On of QCAD.

Moderator: andrew

Post Reply
jamby
Active Member
Posts: 39
Joined: Fri Jun 24, 2016 2:41 pm

How to switch to IJK absolute

Post by jamby » Wed Nov 20, 2019 11:36 pm

Hi
I've tried checking the box in the Edit/Application Preferences/Cam/Cam Export but after restarting Qcad and creating a new drawing the output is still IJK incremental.
Reading the post in the Trouble Shooting and Problems about Circles and CNC I am probably even less likely to figure out what I need to do to change over.
Is there another setting I need to change?


I am running Centos 7 and Qcad 3.18.1

Thanks
Jim

User avatar
andrew
Site Admin
Posts: 6422
Joined: Fri Mar 30, 2007 6:07 am

Re: How to switch to IJK absolute

Post by andrew » Thu Nov 21, 2019 9:54 am

jamby wrote:
Wed Nov 20, 2019 11:36 pm
I've tried checking the box in the Edit/Application Preferences/Cam/Cam Export
You're likely looking at Edit > Application Preferences > CAM > CAM Import.

Everything to do with G-Code generation (CAM Export) is handled by the post processor.

To use absolute I/J coordinates, the codes for arcs have to be overridden in your post processor as follows:

Code: Select all

this.firstArcCWMove =            "[N] G2 [X] [Y] [IA] [JA] [F]";
this.arcCWMove =                 "[N] G2 [X] [Y] [IA] [JA] [F]";

this.firstArcCCWMove =           "[N] G3 [X] [Y] [IA] [JA] [F]";
this.arcCCWMove =                "[N] G3 [X] [Y] [IA] [JA] [F]";
See also:
https://qcad.org/en/qcad-cam-postprocessor

Post Reply

Return to “QCAD/CAM”