Page 1 of 1

Building qcadlib- professional

Posted: Wed Oct 29, 2008 7:48 am
by Bruce Chung

I have problem building qcad with souce of qcadlib- professional edition.

The error on the screen is:

g++ -static-libgcc -L. -Wl,-rpath,/usr/local/Trolltech/Qt-4.4.3/lib -o qcad .obj/qc_applicationwindow.o .obj/qc_application.o .obj/main.o .obj/moc_qc_applicationwindow.o .obj/moc_qc_application.o .obj/qrc_qcad.o -L/usr/local/Trolltech/Qt-4.4.3/lib -L/usr/local/Trolltech/Qt-4.4.3/plugins/codecs -lqjpcodecs -lqcncodecs -lqkrcodecs -lqtwcodecs -L/usr/local/Trolltech/Qt-4.4.3/plugins/imageformats -lqjpeg -lqgif -lQtAssistantClient -L../qcadguiqt/lib -lqcadguiqt -L../qcadactions/lib -lqcadactions -L../qcadprop/lib -lqcadprop -L../qcadlib/lib -lqcad -L../dxflib/lib -llibdxf -L../fparser/lib -lfparser -lQtGui -L/usr/local/Trolltech/Qt-4.4.3/lib -L/usr/X11R6/lib -lXext -lX11 -lQtCore -lm -lrt -ldl -lpthread
.obj/main.o: In function `__static_initialization_and_destruction_0(int, int)':
main.cpp:(.text+0x7ef): undefined reference to `qt_plugin_instance_QJpegPlugin()'
main.cpp:(.text+0x7fb): undefined reference to `qt_plugin_instance_QGifPlugin()'
main.cpp:(.text+0x807): undefined reference to `qt_plugin_instance_qcncodecs()'
main.cpp:(.text+0x813): undefined reference to `qt_plugin_instance_qjpcodecs()'
main.cpp:(.text+0x81f): undefined reference to `qt_plugin_instance_qkrcodecs()'
main.cpp:(.text+0x82b): undefined reference to `qt_plugin_instance_qtwcodecs()'
collect2: ld returned 1 exit status
make: *** [qcad] Error 1

building platform is Ubuntu 8.04 with Qt 4.4.3

The same error was on Win XP plus MinGW-g++ plus Qt4.4.3

Thanks in advance for your help


problem solved

Posted: Sat Nov 01, 2008 9:02 am
by Bruce Chung

With the help of sopport people of Trolltech, this problem has been solved.

Qcad link "static" Qt library. So after I rebuild Qt4.4.3 with the the static option by
./configure -static, making Qt4.4.3 and rebuilding Qcad, everthing was done OK,