Page 1 of 1

QCAD Application Font Looks Odd

Posted: Thu May 16, 2019 5:47 pm
by dklann
Hi! I am using QCAD version 3.22.0 on Arch Linux, with the GNOME 3.32 desktop. Previous versions have had this problem as well.

The application font (menu text, dialog boxes, etc.) appears messed up to me. Actual drawing text appears fine, and text in other Qt applications looks normal. See the attached screenshot for an example.

I have deleted $HOME/.config/QCAD/QCAD3.conf and still the application font looks odd.

I would appreciate learning how to make the QCAD application font look "normal".

Thanks for your thoughts!


Re: QCAD Application Font Looks Odd

Posted: Thu May 16, 2019 6:15 pm
by andrew
This could be any number of things to do with X11, Qt, your window manager, etc.

This is what I'd try first:
- Move all libQt5* files from your QCAD directory into a temporary directory. QCAD comes with its own Qt libraries. By doing this, you can use your systems Qt libraries instead. This might fix the problem or it might mean you can't start QCAD anymore at all...

You also might want to ask in the ArchLinux forum. This thread seems at least related and suggests a fix in /etc/fonts/local.conf: ... 1#p1350501

[SOLVED] QCAD Font Hinting on Linux (was "QCAD Application Font Looks Odd")

Posted: Fri May 17, 2019 8:32 pm
by dklann
Thanks for your reply @andrew. It was not (directly) either of your suggestions that solved my font display issue. But ...

You were correct: moving the QT5 libraries out of the QCAD runtime directory caused QCAD to not start. The error I received was:
./qcad-bin: relocation error: $HOME/opt/qcad-3.22.0-pro-linux-x86_64/plugins/script/ symbol _ZdlPvm version Qt_5 not defined in file with link time reference
(substitute your home directory for $HOME)

I looked through the Arch forum post you linked to and that gave me more font-related things to look for.

Using strace(1) to launch QCAD from the command line, I looked for all references to "font", and found that QCAD was opening

I simply moved that file out of the way and QCAD's fonts look fine now. Maybe someone with more knowledge or experience with font configuration could adjust the settings in that file and leave it in place...

Thanks again for your suggestions!

Here is the entire contents of the file from my system for my future self, and for others who might encounter this:

Code: Select all

<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
 <match target="font">
  <edit mode="assign" name="rgba">
 <match target="font">
  <edit mode="assign" name="hinting">
 <match target="font">
  <edit mode="assign" name="hintstyle">
 <match target="font">
  <edit mode="assign" name="antialias">