keyboard layout -- again *CLOSED*

If you are having problems with QCAD, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post Reply
matita
Newbie Member
Posts: 5
Joined: Sun Jan 07, 2018 9:08 pm

keyboard layout -- again *CLOSED*

Post by matita » Sun Nov 18, 2018 1:00 pm

The strangest thing in over ten years of qcad quirks.

Using QCad 3.19.2.0 (3.19.2) under Arch Linux. It was working normally three days ago. I have not updated anything on the box. Today, the QCad command line is using a different keyboard layout -- possibly English. My locale settings are all "fr_FR.UTF-8" (except LC_COLLATE of course).

Can anyone suggest somewhere that QCad or QT or some perl module stores a keyboard layout setting? All other applications are using the correct (French) keyboard. I have looked at ~/.config/QCAD/QCAD3.conf but there seems to be nothing relevant there, and I can see no other configuration files.

TIA

No responses, but I am marking this closed. After more than a decade using QCad, it is time to move on. I have completed the drawings on LibreCad, which is based on the way QCad used to be, before the slow creep of new features made it so inconsistent in use. And the world of 2D/3D CAD has advanced hugely in the mean time -- there is plenty of choice and the only problem is choosing which to work with.

Although I am leaving, I would like to thank Andrew Mustun for his tireless work and offer best wishes for the future.

--richard

User avatar
andrew
Site Admin
Posts: 6183
Joined: Fri Mar 30, 2007 6:07 am

Re: keyboard layout -- again *CLOSED*

Post by andrew » Tue Nov 20, 2018 7:12 pm

Thanks for the feedback. I wish you success with your future endeavours.

Post Reply

Return to “QCAD Troubleshooting and Problems”