Page 1 of 1

Compiling QCAD from source

Posted: Thu May 30, 2019 2:01 am
by daileyj93
I am having trouble compiling QCAD from the source. I cloned the git repository and tried following the "Compiling QCAD" instructions on the website.
First I downloaded QT 5.5.1 using the installer. Then I downloaded Visual Studio Community and Windows SDK 10.0.18362.1. Next I ran "qmake -r" from the windows cmd. It ran for awhile then I got "The syntax of the command is incorrect" as shown in the attached image "qmake_result.png". After that I also tried running "nmake release" from the Visual Studio Command Prompt, which ran untill I got "NMAKE : fatal error U1077 : return code '0x2'" as shown in attached image "nmake_result.png".
Can someone tell me what I am doing wrong. Let me know if you need more information.
Thank you.

Re: Compiling QCAD from source

Posted: Thu May 30, 2019 10:15 am
by andrew
My first guess would be to avoid spaces in your QCAD sources path...

Re: Compiling QCAD from source

Posted: Fri May 31, 2019 1:11 am
by daileyj93
Thanks andrew! That seemed to do the trick for qmake but I still get the fatal error while running nmake. Any ideas why? Google seems to suggest it is an issue with my environment. Maybe I need to set a PATH for something? I am running nmake from the Visual Studio 2019 command prompt.

SWEET!.. I figured it out. I downloaded Visual Studio 2013 and used the AMD64 Native Tools Command Prompt instead of the Developer Command Prompt and everything went smooth from there! I maybe could have still used VS 2019 if I had used the correct command prompt but I will have to test that in the future sometime.

Thanks for your help!