Search found 34 matches

by MPN
Thu Nov 28, 2019 9:13 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

Andrew has fixed this hatch viewport issue in Snapshot 3.23.0.9.

Marking thread as solved.
by MPN
Mon Nov 25, 2019 9:45 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

Husky wrote:
Mon Nov 25, 2019 9:30 am
Maybe somebody else is more helpful to you.
I will use your workaround of exploding the hatch until this gets fixed. Thank you for your input.
by MPN
Mon Nov 25, 2019 9:11 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

After looking more into this issue is seems it is the Viewport’s position that is ignored when transforming the pattern into Viewport space. Note that the Viewport scale is correctly taken into consideration when transforming the hatch pattern from model space to viewport space. See the following gi...
by MPN
Sun Nov 24, 2019 9:47 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

The reason I bring this issue up is that clipping the hatch pattern works correctly in the Viewport, it seems to be a translation of the hatch pattern that is missing.
by MPN
Sun Nov 24, 2019 9:42 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

I have attached the HatchTesting.dxf in my first post which shows the problem in a simple setup. Thanks
by MPN
Sun Nov 24, 2019 9:17 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

Maybe the issue is more clear when showing it with a real world project (and not a simplified example for a bug report):

Model:
Image

Layout:
Image

I would not expect to have to explode hatches to make this work.
by MPN
Sun Nov 24, 2019 9:11 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

Re: 3.23.0: Hatch is offset incorrectly in Viewport

Viewports are a 'view' of the Model so I would expect to have the same appearance as in the Model. As with all other elements (lines, dimensions etc).
by MPN
Sun Nov 24, 2019 8:46 am
Forum: QCAD Troubleshooting and Problems
Topic: [solved] 3.23.0: Hatch is offset incorrectly in Viewport
Replies: 12
Views: 510

[solved] 3.23.0: Hatch is offset incorrectly in Viewport

Hi, When a hatch have been offset in the Model then it appears incorrectly when rendered in a Viewport. It seems that in Viewports the hatch Origin value is not taken into consideration. This means that when adjusting a hatch in the Model to look correct (align along a line for example). This alignm...
by MPN
Sat Nov 23, 2019 3:56 pm
Forum: QCAD 'How Do I' Questions
Topic: How to create a custom hatch?
Replies: 8
Views: 982

Re: How to create a custom hatch?

Hi CVH

Thanks a bunch for creating the .pat files!
I will play around with creating my own hatches as well now.

Cheers
by MPN
Sun Nov 17, 2019 7:25 pm
Forum: QCAD Troubleshooting and Problems
Topic: [solved] Snapshot issue for 3.23.06: Dimension text not showing in Layouts
Replies: 12
Views: 922

Re: Snapshot issue for 3.23.06: Dimension text not showing in Layouts

Andrew has already submitted a fix for the issue in this thread so marking it as solved
by MPN
Sat Nov 16, 2019 11:06 pm
Forum: QCAD Troubleshooting and Problems
Topic: [solved] Snapshot issue for 3.23.06: Dimension text not showing in Layouts
Replies: 12
Views: 922

Re: Snapshot issue for 3.23.06: Dimension text not showing in Layouts

On the note of scaling dimensions: It would be awesome to have an extra scale factor on viewports that only affected the dimensions of that viewport. Something maybe called: 'Dimensions scale'. Then I could keep my 0.15 cm dimensions in a viewport with scale 1:50 by setting 'Dimension scale = 0.5'. ...
by MPN
Sat Nov 16, 2019 9:01 pm
Forum: QCAD Troubleshooting and Problems
Topic: [solved] Snapshot issue for 3.23.06: Dimension text not showing in Layouts
Replies: 12
Views: 922

Re: Snapshot issue for 3.23.06: Dimension text not showing in Layouts

1. Yes, I would consider that as a bug too. Please fill the bug report below https://www.qcad.org/bugtracker I recommend to work with QCAD Pro 3.23.0 until a solution is available Husky-2019.11.16-02.png Thanks. I have reported the bug here: https://www.qcad.org/bugtracker/index.php?do=details&task...

Go to advanced search