QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD/CAM
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3.23.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by H. Stiekema - 09.11.2019
Last edited by Andrew - 11.11.2019

FS#1992 - Regenerate All Error

Hallo Andrew,

I experienced some odd behaviour when using a final Regenerate All before an Export.

Closed by  Andrew
11.11.2019 12:56
Reason for closing:  Fixed
Admin
Andrew commented on 11.11.2019 07:40

Please attach the DXF file, thanks.

H. Stiekema commented on 11.11.2019 08:15

Attached file is made toolpath one by one, without a generate all
An generate all should produce the error.

H. Stiekema commented on 11.11.2019 09:53

Double checking creating single toolpaths the same Inside / outside error also appeared.

Sometimes the selection gets lost, sometimes the toolpath-attributes were not updated.

Admin
Andrew commented on 11.11.2019 11:10

There are two problems:
- The contour consists of loose entities which leads to different results, depending on where the algorithm starts identifying contours.
- There are tiny gaps in the contour. Usually not a problem, but in this case, it can lead to the algorithm not being able to determine the orientation of the contour.

Both problems can be solved by converting the contour to a polyline (preferably logically closed). Polylines have no gaps (by definition) and the start and end are clearly defined.

H. Stiekema commented on 11.11.2019 12:21

Sounds to be the cause, however,

I tested closed lining (layer outline) by trying a full hatch off all outline entities; if that's goes well then all entities are end-&-startpoint alligned; polylines should not be needed at all.

Tiny gaps in the contour should not been there; the original drawing is an Acad R10 dxf exported. Which entities (handles) are gapped? So I can check where in the proces these gaps appear.

The big surprise here is not a failing contour (by gaps), but the fact that creating a single toolpath goes OK, but that is does not when using Regenerating All. This implies a change in the toolpath's start- or endpoint and/or selection; and that is odd.

Admin
Andrew commented on 11.11.2019 12:56

If there are arcs involved there are always tiny gaps. Arc calculations involve PI, an infinite fraction that cannot be represented accurately by computers. Polylines work around this limitation by eliminating the duplicate presence of vectors (i.e. defining vertices instead of segments).

This implies a change in the toolpath's start- or endpoint and/or selection; and that is odd.

Again: this has to do with the fact that the contour is defined by loose entities. No start point is defined and the algorithm gets to choose everytime you regenerate where to start. If you regenerate multiple times, you will get different results. This information is not stored in DXF either. The first generation can be correct or wrong but just happened to be correct in your case.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing